blob: 21dd1deb65b664fd69a9b67748f9be5f748ab9aa [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001# This recipe is intended as a 'simpler' replacement for packagegroup-base.
2# Please communicate your use cases and suggestions to the mailinglist(s)
3
4SUMMARY = "Basic task to get a device online"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
7
8PR = "r13"
9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11inherit packagegroup
12inherit bluetooth
13
14# Poke extra recomendations into the list using your machine.conf
15#
16MACHINE_EXTRA_RRECOMMENDS ?= ""
17
18#
19# Select between dropbear and openssh
20# Set TASK_BASIC_SSHDAEMON = "openssh-sshd openssh-sftp openssh-sftp-server" in your DISTRO config to get openssh(d)
21#
22TASK_BASIC_SSHDAEMON ?= "dropbear openssh-sftp openssh-sftp-server"
23
24#
25# The section below is designed to match with packagegroup-boot, but doesn't depend on it to allow for more freedom
26# when writing image recipes.
27# It also avoids the choice between connman/networkmanager/ifupdown since that is an image feature, not a
28# distro feature.
29#
30# Util-linux (u)mount is included because the busybox one can't handle /etc/mtab being symlinked to /proc/mounts
31#
32RDEPENDS_${PN} = "\
33 ${TASK_BASIC_SSHDAEMON} \
34 avahi-daemon avahi-utils \
35"
36
37#
38# The following section is split in 3:
39# 1) Machine features: kernel modules and userspace helpers for those
40# 2) Distro features: packages associated with those
41# 3) Nice to have: packages that are nice to have, but aren't strictly needed
42#
43RRECOMMENDS_${PN} = "\
44 ${MACHINE_EXTRA_RRECOMMENDS} \
45 ${@bb.utils.contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \
46 ${@bb.utils.contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \
47 ${@bb.utils.contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \
48 \
49 ${@bb.utils.contains("DISTRO_FEATURES", "bluetooth", "${BLUEZ}", "", d)} \
50 ${@bb.utils.contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \
51 \
52 tzdata \
53 \
54 cpufrequtils \
55 htop \
56"