blob: 51243c2374d2fe685dd83fadc9eb94c05ca38954 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "Concurrency Kit provides a plethora of concurrency primitives, \
2safe memory reclamation mechanisms and non-blocking data structures \
3designed to aid in the design and implementation of high performance \
4concurrent systems."
5
6LICENSE = "BSD & Apache-2.0"
7HOMEPAGE = "http://concurrencykit.org"
8SECTION = "base"
9
10PV = "0.5.1+git${SRCPV}"
11SRCREV = "f97d3da5c375ac2fc5a9173cdd36cb828915a2e1"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=a0b24c1a8f9ad516a297d055b0294231"
13SRC_URI = "git://github.com/concurrencykit/ck.git;protocol=https \
14 file://cross.patch \
15"
16
17S = "${WORKDIR}/git"
18
19COMPATIBLE_HOST = "(i.86|x86_64|powerpc|powerpc64).*-linux*"
20
21inherit autotools-brokensep
22
23PLAT_powerpc64 = "ppc64"
24PLAT ?= "${HOST_ARCH}"
25
26do_configure () {
27 export PLATFORM=${PLAT}
28 export COMPILER='gcc'
29 ${S}/configure \
30 --prefix=${prefix} \
31 --includedir=${includedir} \
32 --libdir=${libdir}
33}
34
35do_compile () {
36 oe_runmake
37}
38
39do_install () {
40 oe_runmake 'DESTDIR=${D}' install
41}