blob: d006d83aa507966fd78527d69d120a5facd433aa [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001# Copyright (C) 2015 Igor Santos <igor.santos@aker.com.br>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Exuberant Ctags"
5DESCRIPTION = "Exuberant Ctags is a multilanguage reimplementation of the \
6 Unix ctags utility. Ctags generates an index of source code \
7 definitions which is used by numerous editors and utilities \
8 to instantly locate the definitions."
9
10HOMEPAGE = "http://ctags.sourceforge.net/"
11
12LICENSE = "GPLv2"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
14
15inherit autotools-brokensep
16
17SRC_URI = "http://prdownloads.sourceforge.net/${BPN}/${BP}.tar.gz"
18
19SRC_URI[md5sum] = "c00f82ecdcc357434731913e5b48630d"
20SRC_URI[sha256sum] = "0e44b45dcabe969e0bbbb11e30c246f81abe5d32012db37395eb57d66e9e99c7"
21
22do_install() {
23 install -Dm 755 ${B}/ctags ${D}${bindir}/ctags
24 install -Dm 644 ${B}/ctags.1 ${D}${mandir}/man1/ctags.1
25}