blob: 62b2796181d5c3cb7bbf74634b97382c33e12ddb [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Install a Debian system into a subdirectory"
2HOMEPAGE = "https://wiki.debian.org/Debootstrap"
3SECTION = "devel"
4LICENSE = "debootstrap-custom-license"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=1e68ced6e1689d4cd9dac75ff5225608"
6
7inherit pkgconfig
8
9SRC_URI = "\
10 http://http.debian.net/debian/pool/main/d/debootstrap/debootstrap_1.0.67.tar.gz \
11 file://devices.tar.gz;unpack=0 \
12"
13
14SRC_URI[md5sum] = "eacabfe2e45415af60b1d74c3a23418a"
15SRC_URI[sha256sum] = "0a12e0a2bbff185d47711a716b1f2734856100e8784361203e834fed0cffa51b"
16
17S = "${WORKDIR}/${BP}"
18
19# All Makefile does is creation of devices.tar.gz, which fails in OE build, we use
20# static devices.tar.gz as work around
21# | NOTE: make -j 8 -e MAKEFLAGS=
22# | rm -rf dev
23# | mkdir -p dev
24# | chown 0:0 dev
25# | chown: changing ownership of `dev': Operation not permitted
26# | make: *** [devices.tar.gz] Error 1
27# | WARNING: exit code 1 from a shell command.
28do_compile_prepend() {
29 cp ${WORKDIR}/devices.tar.gz ${B}
30}
31
32do_install() {
33 oe_runmake 'DESTDIR=${D}' install
34 chown -R root:root ${D}${datadir}/debootstrap
35}