blob: 25e60013d9fb4db0629670e66cf288e176761533 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "IPTraf is a console-based network statistics utility for Linux. \
2It gathers a variety of figures such as TCP connection packet and byte counts, \
3interface statistics and activity indicators, TCP/UDP traffic breakdowns, \
4and LAN station packet and byte counts."
5
6HOMEPAGE = "http://iptraf.seul.org"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=dc0bdc29df738baf327368b1bbb15a45"
10
11DEPENDS = "ncurses"
12
13SRC_URI = " \
14 ftp://iptraf.seul.org/pub/iptraf/iptraf-3.0.0.tar.gz \
15 file://0001-src-Fix-error-in-cross-compile.patch"
16SRC_URI[md5sum] = "377371c28ee3c21a76f7024920649ea8"
17SRC_URI[sha256sum] = "9ee433d95573d612539da4b452e6cdcbca6ab6674a88bfbf6eaf12d4902b5163"
18RDEPENDS_${PN} = "ncurses"
19
20EXTRA_OEMAKE = "-e MAKEFLAGS="
21
22do_compile() {
23 oe_runmake -C src all
24}
25
26do_install() {
27 install -d ${D}${bindir}
28 oe_runmake -C src install \
29 TARGET=${D}${bindir} \
30 WORKDIR=${D}${localstatedir}/local/iptraf \
31 LOGDIR=${D}${localstatedir}/log/iptraf \
32 LOCKDIR=${D}${localstatedir}/run/iptraf
33}
34
35FILES_${PN} += "${bindir} ${localstatedir} /run"