blob: 612eaf39607a69c8ac31ce6a00038503db96452c [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Lightweight and flexible command-line JSON processor"
2DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \
3 filter and map and transform structured data with the same \
4 ease that sed, awk, grep and friends let you play with text."
5HOMEPAGE = "http://stedolan.github.io/jq/"
6BUGTRACKER = "https://github.com/stedolan/jq/issues"
7SECTION = "utils"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=29dd0c35d7e391bb8d515eacf7592e00"
11
12DEPENDS = "flex-native bison-native onig"
13
14SRC_URI = "https://github.com/stedolan/${BPN}/releases/download/${BPN}-${PV}/${BPN}-${PV}.tar.gz \
15"
16
17SRC_URI[md5sum] = "0933532b086bd8b6a41c1b162b1731f9"
18SRC_URI[sha256sum] = "c4d2bfec6436341113419debf479d833692cc5cdab7eb0326b5a4d4fbe9f493c"
19
20inherit autotools
21
22# Don't build documentation (generation requires ruby)
23EXTRA_OECONF = "--disable-docs --disable-maintainer-mode"