blob: bc4e27166dabfb816fba01b0048199559327542d [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "ltrace intercepts and records dynamic library calls"
2
3DESCRIPTION = "ltrace intercepts and records dynamic library calls \
4which are called by an executed process and the signals received by that process. \
5It can also intercept and print the system calls executed by the program.\
6"
7HOMEPAGE = "http://ltrace.org/"
8
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
11
12PE = "1"
13PV = "7.3+git${SRCPV}"
14SRCREV = "37ecc41b58be3dbdd79592a76e331b5b371e4f81"
15
16DEPENDS = "elfutils"
17RDEPENDS_${PN} = "elfutils"
18SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git;branch=ltrace-0.7 \
19 file://ltrace-0.7.2-unused-typedef.patch \
20 file://configure-allow-to-disable-selinux-support.patch \
21 file://0001-ltrace-fix-gcc-5-logical-not-parentheses.patch \
22 "
23S = "${WORKDIR}/git"
24
25inherit autotools
26
27PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
28PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind"
29PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux"
30
31do_configure_prepend () {
32 ( cd ${S}; ./autogen.sh )
33}