blob: 825215372c442e99393cd12ca1b30f68660b4ad5 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Display virtual memory allocation"
2DESCRIPTION = "Lists all the processes, executables, and shared libraries \
3that are using up virtual memory. It's helpful to see how the shared memory \
4is used and which 'old' libs are loaded. \
5"
6HOMEPAGE = "http://memstattool.sourceforge.net/"
7SECTION = "devtool"
8
9LICENSE = "GPLv2"
10
11S = "${WORKDIR}/memstattool"
12
13LIC_FILES_CHKSUM = "file://debian/copyright;md5=87be186443b1ac2cfa466f475e1ee0cb"
14
15SRC_URI = "http://sourceforge.net/projects/memstattool/files/memstat_${PV}.tar.gz \
16 "
17
18SRC_URI[md5sum] = "2c3acc0c62b2a18f6601b84e54aa7462"
19SRC_URI[sha256sum] = "245d5fc7fb87bcfd14486cd34917cae2856e799559ac568434af12c4852bce94"
20
21do_install_append(){
22 install -d ${D}${bindir}
23 install -m 0755 memstat ${D}${bindir}
24 install -d ${D}${sysconfdir}
25 install -m 0755 memstat.conf ${D}${sysconfdir}
26 install -d ${D}${mandir}/man1
27 install -m 0644 memstat.1 ${D}${mandir}/man1
28 install -d ${D}${docdir}/${BPN}
29 install -m 0644 memstat-tutorial.txt ${D}${docdir}/${BPN}
30}