blob: 7d009068d8dac4768468f96afb73b67f78f002a1 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Message Passing Interface (MPI) implementation"
2HOMEPAGE = "http://www.mpich.org/"
3SECTION = "devel"
4
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=2106f0435056f3dd9349747a766e5816"
7
8SRC_URI = " \
9 http://www.mpich.org/static/downloads/${PV}/mpich-${PV}.tar.gz \
10"
11
12SRC_URI[md5sum] = "40dc408b1e03cc36d80209baaa2d32b7"
13SRC_URI[sha256sum] = "455ccfaf4ec724d2cf5d8bff1f3d26a958ad196121e7ea26504fd3018757652d"
14
15CACHED_CONFIGUREVARS += "BASH_SHELL=${base_bindir}/bash"
16
17RDEPENDS_${PN} += "bash perl libxml2"
18S = "${WORKDIR}/${BP}"
19
20EXTRA_OECONF = "--enable-debuginfo \
21 --enable-fast \
22 --enable-shared \
23 --with-pm=gforker \
24 --disable-rpath \
25 --disable-f77 \
26 --disable-fc \
27 --disable-fortran \
28 --disable-cxx"
29
30inherit autotools-brokensep gettext
31
32do_configure_prepend() {
33 autoreconf --verbose --install --force -I . -I confdb/ -I maint/
34 oe_runconf
35 exit
36}
37
38# http://errors.yoctoproject.org/Errors/Details/35146/
39PNBLACKLIST[mpich] ?= "BROKEN: QA Issue: libmpi.la failed sanity test (workdir), QA Issue: mpich.pc failed sanity test (tmpdir)"