blob: c00710afd51c3d15a651d17d84ba44ac17f20753 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Ninja is a small build system with a focus on speed."
2HOMEPAGE = "http://martine.github.com/ninja/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
5
6DEPENDS = "re2c-native"
7
8inherit native
9
10SRCREV="484c16336f19bd8970bb6e75322d61b92a229899"
11
12SRC_URI = "git://github.com/martine/ninja.git;branch=release"
13
14S="${WORKDIR}/git"
15
16do_configure[noexec] = "1"
17
18do_compile() {
19 python ${S}/configure.py --bootstrap
20}
21
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 ${S}/ninja ${D}${bindir}/
25}