blob: 66054a257fd308787c60a76d9e9f12540d4e43aa [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "\
2IPC::Run allows you run and interact with child processes \
3using files, pipes, and pseudo-ttys. Both system()-style and scripted \
4usages are supported and may be mixed. Likewise, functional and OO API \
5styles are both supported and may be mixed."
6SECTION = "libs"
7LICENSE = "Artistic-1.0 | GPL-1.0+"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=0ebd37caf53781e8b7223e6b99b63f4e"
9DEPENDS = "perl"
10
11SRC_URI = "git://github.com/toddr/IPC-Run.git"
12SRCREV = "6bdf41e276e06d23e140783b13a6eaef4745c216"
13
14S = "${WORKDIR}/git"
15
16inherit cpan
17
18EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
19
20do_compile() {
21 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
22 cpan_do_compile
23}