blob: 4961d7b83f3fa44684ee4f938a255dac83a15664 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Small and fast POSIX-compliant shell"
2HOMEPAGE = "http://gondor.apana.org.au/~herbert/dash/"
3SECTION = "System Environment/Shells"
4
5LICENSE = "BSD & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b5262b4a1a1bff72b48e935531976d2e"
7
8inherit autotools update-alternatives
9
10SRC_URI = "http://gondor.apana.org.au/~herbert/${BPN}/files/${BP}.tar.gz"
11SRC_URI[md5sum] = "5c152209680dab3c319e8923f6c51378"
12SRC_URI[sha256sum] = "c6db3a237747b02d20382a761397563d813b306c020ae28ce25a1c3915fac60f"
13
14EXTRA_OECONF += "--bindir=${base_bindir}"
15
16ALTERNATIVE_${PN} = "sh"
17ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
18ALTERNATIVE_TARGET[sh] = "${base_bindir}/dash"
19ALTERNATIVE_PRIORITY = "10"
20
21pkg_postinst_${PN} () {
22 grep -q "^${base_bindir}/dash$" $D${sysconfdir}/shells || echo ${base_bindir}/dash >> $D${sysconfdir}/shells
23}
24
25pkg_postrm_${PN} () {
26 printf "$(grep -v "^${base_bindir}/dash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
27}