blob: f7a4d55a0500969e66ef5e16e1a6f0782456c275 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhinstaller/efivar"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8DEPENDS_class-target = "popt efivar-native"
9
10SRCREV = "aab6c2a64d90b6e5a63661fb5bd6be8d878b0784"
11SRC_URI = "git://github.com/rhinstaller/efivar.git"
12SRC_URI_append_class-target = " file://0001-efivar-fix-for-cross-compile.patch"
13SRC_URI_append_class-native = " file://efivar-drop-options-not-supported-by-lower-version-gcc.patch"
14
15S = "${WORKDIR}/git"
16
17do_install() {
18 oe_runmake install DESTDIR=${D}
19}
20
21do_compile_class-native() {
22 oe_runmake -C src makeguids
23}
24
25do_install_class-native() {
26 install -D -m 0755 ${B}/src/makeguids ${D}${bindir}/makeguids
27}
28
29BBCLASSEXTEND = "native"
30
31# See
32# http://lists.openembedded.org/pipermail/openembedded-core/2016-February/116564.html
33# http://lists.openembedded.org/pipermail/openembedded-core/2016-February/116571.html
34# http://lists.openembedded.org/pipermail/openembedded-devel/2016-February/105802.html
35# http://lists.openembedded.org/pipermail/openembedded-devel/2016-February/105786.html
36# but it's still broken:
37# http://lists.openembedded.org/pipermail/openembedded-devel/2016-February/105825.html
38# http://lists.openembedded.org/pipermail/openembedded-devel/2016-February/105830.html
39PNBLACKLIST[efivar] ?= "BROKEN: linux.c:27:30: fatal error: linux/nvme_ioctl.h: No such file or directory"