blob: 8b0e61b9a8a10e1fcf6900cf012be7c54578b54d [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Firmware testsuite"
2DESCRIPTION = "The tool fwts comprises of over fifty tests that are designed to exercise and test different aspects of a machine's firmware. Many of these tests need super user access to read BIOS data and ACPI tables, so the tool requires running with super user privileges (e.g. with sudo)."
3HOMEPAGE = "https://wiki.ubuntu.com/Kernel/Reference/fwts"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=deb8af5388e838d133eaa036f4d1496f"
7
8PV = "14.09.00"
9
10SRCREV = "cf14f3b4bab716dea95de772ad52786c1cbe862a"
11SRC_URI = "git://kernel.ubuntu.com/hwe/fwts.git"
12
13S = "${WORKDIR}/git"
14
15DEPENDS = "libpcre json-c glib-2.0"
16
17inherit autotools-brokensep
18
19FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}"
20FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la"
21FILES_${PN}-staticdev += "${libdir}/fwts/lib*a"
22FILES_${PN}-dbg += "${libdir}/fwts/.debug"