blob: fbd1992d639e34c9c1b2e82c89fc020d667c8055 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "haveged - A simple entropy daemon"
2DESCRIPTION = "The haveged project is an attempt to provide an easy-to-use, unpredictable random number generator based upon an adaptation of the HAVEGE algorithm. Haveged was created to remedy low-entropy conditions in the Linux random device that can occur under some workloads, especially on headless servers."
3AUTHOR = "Gary Wuertz"
4HOMEPAGE = "http://www.issihosts.com/haveged/index.html"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM="file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8SRC_URI = "http://www.issihosts.com/haveged/haveged-${PV}.tar.gz \
9 file://remove-systemd-unit-503.patch \
10 "
11
12SRC_URI[md5sum] = "015ff58cd10607db0e0de60aeca2f5f8"
13SRC_URI[sha256sum] = "9c2363ed9542a6784ff08e247182137e71f2ddb79e8e6c1ac4ad50d21ced3715"
14
15PR = "r0"
16
17inherit autotools systemd
18
19EXTRA_OECONF = "\
20 --enable-init=service.redhat \
21 --enable-nistest=yes \
22 --enable-olt=yes \
23 --enable-threads=no \
24 "
25
26SYSTEMD_PACKAGES = "${PN}"
27SYSTEMD_SERVICE_${PN} = "haveged.service"
28
29do_install_append() {
30 mkdir -p ${D}${systemd_unitdir}/system
31 install -p -m644 ${B}/init.d/haveged.service ${D}${systemd_unitdir}/system
32}