blob: f57e9dfc6f40ceff729f79dabc4efb9854c45af9 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001require lcdproc5.inc
2
3SRC_URI[md5sum] = "df4f5c2c7285eaf6979b9c7768b4877f"
4SRC_URI[sha256sum] = "bd2f43c30ff43b30f43110abe6b4a5bc8e0267cb9f57fa97cc5e5ef9488b984a"
5
6PACKAGECONFIG ?= ""
7PACKAGECONFIG[g15] = ",,libg15 g15daemon libg15render,"
8PACKAGECONFIG[hid] = "--enable-libhid,--disable-libhid,libhid"
9
10LCD_DRIVERS_append = "${@bb.utils.contains('PACKAGECONFIG', 'g15', '', ',!g15', d)}"
11
12do_install_append () {
13 # binaries
14 install -D -m 0755 clients/lcdvc/lcdvc ${D}${sbindir}/lcdvc
15
16 # configuration files
17 install -D -m 0644 ${S}/clients/lcdvc/lcdvc.conf ${D}${sysconfdir}/lcdvc.conf
18}
19
20PACKAGES =+ "lcdvc"
21CONFFILES_lcdvc = "${sysconfdir}/lcdvc.conf"
22FILES_lcdvc = "${sysconfdir}/lcdvc.conf ${sbindir}/lcdvc"
23