blob: a6a302430169dbf58c6c1d3ffe08a5c20bd91574 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "LevelDB is a fast key-value storage library"
2DESCRIPTION = "LevelDB is a fast key-value storage library that provides an ordered mapping from string keys to string values"
3HOMEPAGE = "http://leveldb.googlecode.com"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=92d1b128950b11ba8495b64938fc164d"
6
7SRCREV = "803d69203a62faf50f1b77897310a3a1fcae712b"
8PV = "1.18+git${SRCPV}"
9
10SRC_URI = "git://github.com/google/${BPN}.git \
11 file://0001-Explicitly-disable-tcmalloc.patch \
12"
13
14S = "${WORKDIR}/git"
15
16do_compile() {
17 # do not use oe_runmake. oe_runmake pass to make compilation arguments and override
18 # leveldb makefile variable CFLAGS and broke leveldb build.
19 CFLAGS="${CFLAGS}" make || die
20}
21
22do_install() {
23 install -d ${D}${libdir}
24 oe_libinstall -C ${S} -so libleveldb ${D}${libdir}
25 install -d ${D}${includedir}/leveldb
26 install -m 644 ${S}/include/leveldb/*.h ${D}${includedir}/leveldb/
27}