blob: 3488b19a3054da27d51dc24f9d8667bd912cfcfb [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "An easy to use logging library"
2DESCRIPTION = " \
3liblogging (the upstream project) is a collection of several components. \
4Namely: stdlog, journalemu, rfc3195. \
5The stdlog component of liblogging can be viewed as an enhanced version of \
6the syslog(3) API. It retains the easy semantics, but makes the API more \
7sophisticated "behind the scenes" with better support for multiple threads \
8and flexibility for different log destinations (e.g. syslog and systemd \
9journal)."
10SECTION = "libs"
11LICENSE = "BSD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=63fe03535d83726f5655072502bef1bc"
13SRC_URI = "http://download.rsyslog.com/${BPN}/${BPN}-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "44b8ce2daa1bfb84c9feaf42f9925fd7"
16SRC_URI[sha256sum] = "310dc1691279b7a669d383581fe4b0babdc7bf75c9b54a24e51e60428624890b"
17
18inherit autotools pkgconfig
19
20EXTRA_OECONF = "--disable-man-pages"
21
22PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "systemd", "systemd", "", d)}"
23PACKAGECONFIG[systemd] = "--enable-journal, --disable-journal, systemd"