blob: ba4c2ab9ace2d280083c8b2279e340ed724e86d8 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Analyzes log files and sends noticeable events as email"
2DESCRIPTION = "\
3Logcheck is a simple utility which is designed to allow a system administrator \
4to view the log-files which are produced upon hosts under their control. \
5It does this by mailing summaries of the log-files to them, after first \
6filtering out "normal" entries. \
7Normal entries are entries which match one of the many included regular \
8expression files contain in the database."
9SECTION = "Applications/System"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=c93c0550bd3173f4504b2cbd8991e50b"
12
13SRC_URI = "git://git.debian.org/git/logcheck/logcheck.git"
14SRCREV = "2429e67ad875fee8a0234c64d504277b038c89cd"
15
16S = "${WORKDIR}/git"
17
18do_install() {
19 # Fix QA Issue
20 sed -i '/install -d $(DESTDIR)\/var\/lock\/logcheck/s/^/#/' Makefile
21
22 # "make install" do not install the manpages. Install them manually.
23 install -m 755 -d ${D}${mandir}/man1
24 install -m 755 -d ${D}${mandir}/man8
25 install -m 644 docs/logcheck-test.1 ${D}${mandir}/man1/
26 install -m 644 docs/logtail.8 ${D}${mandir}/man8/
27 install -m 644 docs/logtail2.8 ${D}${mandir}/man8/
28 sed -i "s/syslog/messages/" etc/logcheck.logfiles
29 sed -i "s/auth\.log/secure/" etc/logcheck.logfiles
30 install -m 755 -d ${D}${sysconfdir}/cron.d
31 install -m 644 debian/logcheck.cron.d ${D}${sysconfdir}/cron.d/logcheck
32 install -m 755 -d ${D}/var/lib/logcheck
33 oe_runmake install DESTDIR=${D}
34}
35
36RDEPENDS_${PN} = "perl"
37
38FILES_${PN} += "${datadir}/logtail"