blob: 5126a31cd6cb93f2215420c96dd3f17b74e3a75a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "nicstat is a Solaris and Linux command-line that prints out network \
2statistics for all network interface cards (NICs), including packets, kilobytes \
3per second, average packet sizes and more."
4HOMEPAGE = "http://nicstat.sourceforge.net"
5LICENSE = "Artistic-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b4a94da2a1f918b217ef5156634fc9e0"
7
8SRC_URI = "http://softlayer-sng.dl.sourceforge.net/project/${BPN}/${BP}.tar.gz"
9SRC_URI[md5sum] = "9a0b87bbc670c1e738e5b40c7afd184d"
10SRC_URI[sha256sum] = "c4cc33f8838f4523f27c3d7584eedbe59f4c587f0821612f5ac2201adc18b367"
11
12do_compile() {
13 ${CC} ${CFLAGS} ${LDFLAGS} -o nicstat nicstat.c
14}
15do_install() {
16 install -d ${D}/${bindir}/
17 install -d ${D}/${mandir}/
18 install -m 0755 ${S}/nicstat ${D}${bindir}/
19 install -m 0644 ${S}/nicstat.1 ${D}/${mandir}/
20}