blob: 54429108beff4f18fccbd6de075d7ff04d3654f8 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "CIM providers for network management"
2DESCRIPTION = "\
3openlmi-networking is set of CMPI providers for network management using \
4Common Information Model (CIM)."
5HOMEPAGE = "http://www.openlmi.org/"
6LICENSE = "LGPL-2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=7c13b3376cea0ce68d2d2da0a1b3a72c"
8SECTION = "System/Management"
9DEPENDS = "openlmi-providers konkretcmpi sblim-cmpi-devel cim-schema-exper networkmanager dbus libcheck glib-2.0"
10
11SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \
12 file://0001-fix-lib64-can-not-be-shiped-in-64bit-target.patch \
13 "
14SRC_URI[md5sum] = "f20de8c76fb6a80001b14c1eb035953e"
15SRC_URI[sha256sum] = "578eaa5c65fe924b5d7aeb635509dd46443166cd6a88b019bc42646e3518a460"
16
17inherit cmake
18
19EXTRA_OECMAKE = "${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \
20 ${@base_conditional("libdir", "/usr/lib32", "-DLIB_SUFFIX=32", "", d)} \
21 "
22
23
24do_configure_prepend() {
25 export CMAKE_INSTALL_DATDIR="${STAGING_DATADIR}"
26}
27
28
29FILES_${PN} =+ "${libdir}/cmpi/libcmpiLMI_Networking.so ${prefix}/libexec*"
30FILES_${PN}-dbg =+ "${libdir}/cmpi/.debug*"