blob: 015d803391072665ad75d4c36044c893152a03b0 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "CIM providers for storage management"
2DESCRIPTION = "\
3The openlmi-storage package contains CMPI providers for management of storage \
4using Common Information Managemen (CIM) protocol. \
5\
6The providers can be registered in any CMPI-aware CIMOM, both OpenPegasus and \
7SFCB were tested."
8HOMEPAGE = "http://www.openlmi.org/"
9LICENSE = "LGPL-2.1+"
10LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
11SECTION = "System/Management"
12DEPENDS = "openlmi-providers pywbem cmpi-bindings"
13RDEPENDS_${PN} += "bash"
14
15SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz"
16SRC_URI[md5sum] = "898cf0d8c03b8ad6b45d65f335ddee0d"
17SRC_URI[sha256sum] = "4a1ba9957750f94ea58a89cea28985564f38d7cc9aa00fcae20c51e7b32bd0a8"
18
19inherit setuptools
20
21do_install_append() {
22 install -m 755 -d ${D}${datadir}/${BPN}
23 install -m 644 ${S}/mof/* ${D}${datadir}/${BPN}/
24
25 install -m 755 -d ${D}${sysconfdir}/openlmi/storage
26 install -m 644 storage.conf ${D}${sysconfdir}/openlmi/storage/storage.conf
27
28 install -m 755 -d ${D}${libexecdir}/pegasus
29 install -m 755 pycmpiLMI_Storage-cimprovagt ${D}${libexecdir}/pegasus/
30}
31
32FILES_${PN} =+ "${sysconfdir}/openlmi/storage/storage.conf ${datadir}/${BPN}/*"