blob: 52b271c114befa098b2f8c91c118541636f6bac1 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Opensource Implementation of WS-Management"
2DESCRIPTION = "Openwsman is a project intended to provide an open-source \
3implementation of the Web Services Management specipication \
4(WS-Management) and to expose system management information on the \
5Linux operating system using the WS-Management protocol. WS-Management \
6is based on a suite of web services specifications and usage \
7requirements that exposes a set of operations focused on and covers \
8all system management aspects. \
9Openwsman Server and service libraries"
10HOMEPAGE = "http://www.openwsman.org/"
11SECTION = "Applications/System"
12
13DEPENDS = "curl libxml2 openssl libpam"
14
15SRCREV = "ed7a119e036c53078d70fd85936d94dc9b9b98be"
16PV = "2.6.2"
17
18SRC_URI = "git://github.com/Openwsman/openwsman.git;protocol=http \
19 file://libssl-is-required-if-eventint-supported.patch \
20 file://openwsmand.service"
21
22S = "${WORKDIR}/git"
23
24LICENSE = "BSD"
25LIC_FILES_CHKSUM = "file://COPYING;md5=d4f53d4c6cf73b9d43186ce3be6dd0ba"
26
27inherit systemd cmake pkgconfig pythonnative perlnative
28
29SYSTEMD_SERVICE_${PN} = "openwsmand.service"
30SYSTEMD_AUTO_ENABLE = "disable"
31
32LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}"
33
34EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \
35 -DBUILD_LIBCIM=NO \
36 -DBUILD_PERL=YES \
37 -DCMAKE_INSTALL_PREFIX=${prefix} \
38 -DLIB=${baselib} \
39 "
40
41do_configure_prepend() {
42 export HOST_SYS=${HOST_SYS}
43 export BUILD_SYS=${BUILD_SYS}
44 export STAGING_INCDIR=${STAGING_INCDIR}
45 export STAGING_LIBDIR=${STAGING_LIBDIR}
46}
47
48do_install_append() {
49 install -d ${D}/${sysconfdir}/init.d
50 install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand
51 ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand
52 chmod 755 ${D}/${sysconfdir}/openwsman/owsmangencert.sh
53 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
54 install -d ${D}/${systemd_unitdir}/system
55 install -m 644 ${WORKDIR}/openwsmand.service ${D}/${systemd_unitdir}/system
56
57 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/openwsmand.service
58 sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/openwsmand.service
59 sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${systemd_unitdir}/system/openwsmand.service
60 fi
61}
62
63FILES_${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \
64 ${libdir}/openwsman/authenticators/.debug/ \
65 "
66
67INSANE_SKIP_${PN} = "dev-so"