blob: b89fc42deac87b53f9d1748c1b69561771b9be8b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "7-zip is a commandline utility handling 7z archives."
2HOMEPAGE = "http://www.7-zip.org/"
3LICENSE = "LGPL-2.1+ & unRAR"
4LIC_FILES_CHKSUM = "file://DOCS/copying.txt;md5=ecfc54c9e37b63ac58900061ce2eab5a \
5 file://DOCS/unRarLicense.txt;md5=9c87ddde469ef94aed153b0951d088de"
6
7SRC_URI = "http://downloads.sourceforge.net/p7zip/p7zip/${PV}/p7zip_${PV}_src_all.tar.bz2 \
8 file://do_not_override_compiler_and_do_not_strip.patch"
9SRC_URI[md5sum] = "bd6caaea567dc0d995c990c5cc883c89"
10SRC_URI[sha256sum] = "49557e7ffca08100f9fc687f4dfc5aea703ca207640c76d9dee7b66f03cb4782"
11
12S = "${WORKDIR}/${BPN}_${PV}"
13
14do_install() {
15 install -d ${D}${bindir}
16 install -m 0755 ${S}/bin/* ${D}${bindir}
17}
18
19# all3: to build bin/7za, bin/7z (with its plugins), bin/7zr and bin/7zCon.sfx
20EXTRA_OEMAKE_class-native = "all3"
21
22do_install_class-native() {
23 install -d ${D}${bindir}
24 install -d ${D}${bindir}/Codecs
25 install -m 0755 ${S}/bin/7* ${D}${bindir}
26 install -m 0755 ${S}/bin/Codecs/* ${D}${bindir}/Codecs
27
28 # Create a shell script wrapper to execute next to 7z.so
29 mv ${D}${bindir}/7z ${D}${bindir}/7z.bin
30 echo "#! /bin/sh" > ${D}${bindir}/7z
31 echo "exec ${D}${bindir}/7z.bin \"\$@\"" >> ${D}${bindir}/7z
32 chmod 0755 ${D}${bindir}/7z
33}
34
35BBCLASSEXTEND += "native"