blob: fdd198a61da3586e9728e9fb757f798a717c3ad5 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "PolicyKit Authorization Framework"
2DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/polkit"
4LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4"
7
8DEPENDS = "expat glib-2.0 intltool-native mozjs"
9
10inherit autotools gtk-doc pkgconfig useradd systemd gobject-introspection
11
12PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
13 ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)}"
14
15PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam"
16PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd"
17# there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS
18PACKAGECONFIG[consolekit] = ",,,consolekit"
19
20PAM_SRC_URI = "file://polkit-1_pam.patch"
21SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
22 file://0001-make-netgroup-support-configurable.patch \
23 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
24"
25SRC_URI[md5sum] = "4b77776c9e4f897dcfe03b2c34198edf"
26SRC_URI[sha256sum] = "e1c095093c654951f78f8618d427faf91cf62abdefed98de40ff65eca6413c81"
27
28EXTRA_OECONF = "--with-os-type=moblin --disable-man-pages"
29
30do_compile_prepend () {
31 export GIR_EXTRA_LIBS_PATH="${B}/src/polkit/.libs"
32}
33
34PACKAGES =+ "${PN}-examples"
35
36FILES_${PN}_append = " \
37 ${libdir}/${BPN}-1 \
38 ${nonarch_libdir}/${BPN}-1 \
39 ${datadir}/dbus-1 \
40 ${datadir}/${BPN}-1 \
41"
42
43FILES_${PN}-examples = "${bindir}/*example*"
44
45USERADD_PACKAGES = "${PN}"
46USERADD_PARAM_${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd"
47
48SYSTEMD_SERVICE_${PN} = "${BPN}.service"
49SYSTEMD_AUTO_ENABLE = "disable"