blob: 55f2c96693eec4453d65c061f1b05cf5f0f208db [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Redis key-value store"
2DESCRIPTION = "Redis is an open source, advanced key-value store."
3HOMEPAGE = "http://redis.io"
4SECTION = "libs"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=3c01b49fed4df1a79843688fa3f7b9d6"
7DEPENDS = ""
8
9SRC_URI = "http://download.redis.io/releases/${BP}.tar.gz \
10 file://hiredis-use-default-CC-if-it-is-set.patch \
11 file://lua-update-Makefile-to-use-environment-build-setting.patch \
12 file://oe-use-libc-malloc.patch \
13 file://redis.conf \
14 file://init-redis-server \
15"
16SRC_URI[md5sum] = "87be8867447f62524b584813e5a7bd14"
17SRC_URI[sha256sum] = "93e422c0d584623601f89b956045be158889ebe594478a2c24e1bf218495633f"
18
19inherit autotools-brokensep update-rc.d
20
21do_install() {
22 export PREFIX=${D}/${prefix}
23 oe_runmake install
24 install -d ${D}/${sysconfdir}/redis
25 install -m 0644 ${WORKDIR}/redis.conf ${D}/${sysconfdir}/redis/redis.conf
26 install -d ${D}/${sysconfdir}/init.d
27 install -m 0755 ${WORKDIR}/init-redis-server ${D}/${sysconfdir}/init.d/redis-server
28 install -d ${D}/var/lib/redis/
29}
30
31CONFFILES_${PN} = "${sysconfdir}/redis/redis.conf"
32
33INITSCRIPT_NAME = "redis-server"
34INITSCRIPT_PARAMS = "defaults 87"