blob: 13f93cc6d0f271480ab25edbcf729509ea7a65a3 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Linux SCSi tools to service maintain disk storage devices"
2DESCRIPTION = "scsirastools were designed to add to the Serviceability of \
3 SCSI devices under Linux so that the system does not have \
4 to be rebooted or taken out of service to perform common \
5 maintenance or service functions. It handles SCSI, \
6 Linux SW RAID, SAS, SATA, and USB devices via SCSI emulation."
7HOMEPAGE = "http://scsirastools.sourceforge.net/"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;md5=687ea108478d26152ae46eb29d9d1545"
10PR = "r0"
11
12SRC_URI = "http://prdownloads.sourceforge.net/scsirastools/scsirastools-${PV}.tar.gz \
13 "
14SRC_URI[md5sum] = "2d775111b62e2dfc1960a722f5fda211"
15SRC_URI[sha256sum] = "38d2c6c9b04a2c594e528927b950754f94c0522718d17c78e6589ba778339bf8"
16
17inherit autotools update-rc.d
18
19# mdadm Makefile has CC set to gcc, hence override CC to ${CC}
20EXTRA_OEMAKE += "CC='${CC}'"
21
22INITSCRIPT_PACKAGES = "${PN}-diskmon ${PN}-raidmon"
23INITSCRIPT_NAME_${PN}-diskmon = "sgdisk"
24INITSCRIPT_PARAMS_${PN}-diskmon = "defaults 80 20"
25INITSCRIPT_NAME_${PN}-raidmon = "sgraid"
26INITSCRIPT_PARAMS_${PN}-raidmon = "defaults 80 20"
27
28PACKAGES =+ "${PN}-diskmon ${PN}-diskmon-dbg"
29PACKAGES =+ "${PN}-raidmon ${PN}-raidmon-dbg"
30
31FILES_${PN}-dbg += "/usr/share/scsirastools/.debug"
32
33FILES_${PN}-diskmon = "${sbindir}/sgdiskmon ${sysconfdir}/init.d/sgdisk"
34FILES_${PN}-diskmon-dbg = "${sbindir}/.debug/sgdiskmon"
35
36FILES_${PN}-raidmon = "${sbindir}/sgraidmon ${sysconfdir}/init.d/sgraid"
37FILES_${PN}-raidmon-dbg = "${sbindir}/.debug/sgraidmon"
38
39RDEPENDS_${PN} += "bash"
40RDEPENDS_${PN}-diskmon += "${PN}"
41RDEPENDS_${PN}-raidmon += "${PN}"