blob: 717fab93abb3b5952249ab08ba8d94946d52648a [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A New System Troubleshooting Tool Built for the Way You Work"
2DESCRIPTION = "Sysdig is open source, system-level exploration: capture \
3system state and activity from a running Linux instance, then save, \
4filter and analyze."
5HOMEPAGE = "http://www.sysdig.org/"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9inherit cmake pkgconfig
10
11DEPENDS = "luajit zlib ncurses"
12RDEPENDS_${PN} = "bash"
13
14SRC_URI = "git://github.com/draios/sysdig.git;branch=master \
15 file://0001-libsinsp-Port-to-build-with-lua-5.2.patch \
16 file://0001-Fix-build-with-musl-backtrace-APIs-are-glibc-specifi.patch \
17 "
18SRCREV = "85d16f33a82a17f87ccdbc088749271c71d87013"
19PV = "0.1.102+git${SRCPV}"
20
21S = "${WORKDIR}/git"
22
23DIR_ETC="/etc"
24EXTRA_OECMAKE = ' -DUSE_BUNDLED_LUAJIT="OFF" \
25 -DUSE_BUNDLED_ZLIB="OFF" \
26 -DBUILD_DRIVER="OFF" \
27 -DUSE_BUNDLED_NCURSES="OFF" \
28 -DDIR_ETC="${DIR_ETC}" \
29 '
30
31FILES_${PN} += " \
32 ${DIR_ETC}/* \
33 ${datadir}/zsh/* \
34 ${prefix}/src/* \
35"