blob: 1dd4cb58041f47e432083208b115088882cecaee [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "TENEX C Shell, an enhanced version of Berkeley csh \
2 The TENEX C Shell is an enhanced version of the Berkeley Unix C shell. \
3 It includes all features of 4.4BSD C shell, plus a command-line editor, \
4 programmable word completion, spelling correction and more."
5
6HOMEPAGE = "http://www.tcsh.org/"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://Copyright;md5=1cf29be62df2be1a3763118b25b4c780"
9SECTION = "base"
10DEPENDS = "ncurses gettext-native"
11SRC_URI = " \
12 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}.orig.tar.gz;name=tarball \
13 ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}-2.diff.gz;name=diffs \
14 file://01_build.1.patch \
15 file://01_build.2.patch \
16 file://01_build.3.patch \
17 file://15_no-strip.patch \
18 file://disable-test-notty.patch \
19 file://disable-test-nice.patch \
20 file://disable-lexical.at-31.patch \
21 file://12_unknown_lscolors.patch \
22 file://tcsh-6.17.02-multibyte.patch \
23 file://disable-broken-test.patch \
24"
25SRC_URI[tarball.md5sum] = "6eed09dbd4223ab5b6955378450d228a"
26SRC_URI[tarball.sha256sum] = "d81ca27851f3e8545666399b4bcf25433e602a195113b3f7c73886fef84c9fa8"
27SRC_URI[diffs.md5sum] = "ea39b818b624aca49ebf2cd2708d6ff9"
28SRC_URI[diffs.sha256sum] = "95b0c1a339b745c47c5d2f9d02c22a71597462e2e882b51614a9d1f75bd3d16c"
29
30inherit autotools
31
32do_install_append () {
33 oe_runmake install.man DESTDIR=${D}
34
35 install -d ${D}${base_bindir}
36 ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh
37
38 install -d ${D}${sysconfdir}/csh/login.d
39 install -m 0644 ${S}/debian/csh.cshrc ${S}/debian/csh.login ${S}/debian/csh.logout ${S}/complete.tcsh ${D}${sysconfdir}
40 install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el
41}
42
43FILES_${PN} += "${datadir}/emacs/site-lisp/csh-mode.el"
44
45
46pkg_postinst_${PN} () {
47#!/bin/sh -e
48echo /usr/bin/tcsh >> $D/etc/shells
49}