blob: 5a981166b8208c35dc255e2479dde7236b530803 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Hardware performance monitoring counters"
2HOMEPAGE = "http://tiptop.gforge.inria.fr/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "ncurses libxml2"
6
7SRC_URI = "http://tiptop.gforge.inria.fr/releases/${BP}.tar.gz"
8SRC_URI[md5sum] = "f1fba1e90465b0e5a3865b19133fa19d"
9SRC_URI[sha256sum] = "3f07e958b40acaeab98e9eb1326c9f91b0be0a782c1cc2bd7a9e18d31fab18ca"
10
11inherit autotools-brokensep
12EXTRA_OECONF = "CFLAGS="$CFLAGS -I${STAGING_INCDIR}/libxml2""
13COMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc).*-linux"
14
15do_configure_prepend () {
16 # Two bugs in configure.ac when cross-compiling.
17 # 1. The path of libxml2. Specify it in EXTRA_OECONF.
18 # 2. hw's value on other platforms. Replace it if the target is
19 # not i*86/x86_64.
20 if ( echo "${TARGET_ARCH}" | grep -q -e 'i.86' -e 'x86_64' ); then
21 sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac
22 else
23 sed -i 's/hw=`uname -m`/hw="unknown"/' ${S}/configure.ac
24 sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac
25 fi
26}