blob: 70229f014e2e04c57a68ca998f485e9e55f56fd9 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A UNIX tool for secure deletion"
2DESCRIPTION = "Wipe is a little command for securely erasing files from \
3magnetic media. It compiles under various unix platforms, \
4including Linux 2. * , (Open, Net, Free)BSD, aix 4.1, SunOS \
55.5.1, Solaris 2.6. wipe is released under the GPL. Pre-compiled \
6packages are available on most Linux distributions. \
7Under Debian, the package name is wipe"
8HOMEPAGE = "http://lambda-diode.com/software/wipe/"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://GPL;md5=0636e73ff0215e8d672dc4c32c317bb3"
11
12SRC_URI = "git://github.com/berke/wipe.git;branch=master \
13 file://support-cross-compile-for-linux.patch \
14 "
15SRCREV = "d9c100c9cd0b1cbbe4359e4d6c9a035d11e7597c"
16PV = "0.23+git${SRCPV}"
17
18S = "${WORKDIR}/git"
19
20EXTRA_OEMAKE = "linux"
21
22do_install() {
23 make install DESTDIR=${D}
24}
25
26do_configure[noexec] = "1"