blob: 39b2d95a6962993a4c520969b7bf6d36d020b2ab [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "UNIX Shell similar to the Korn shell"
2DESCRIPTION = "Zsh is a shell designed for interactive use, although it is also a \
3 powerful scripting language. Many of the useful features of bash, \
4 ksh, and tcsh were incorporated into zsh; many original features were added."
5HOMEPAGE = "http://www.zsh.org"
6SECTION = "base/shell"
7
8LICENSE = "zsh"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=b7bc853894664be455a922db9805288e"
10
11DEPENDS = "ncurses bison-native libcap libpcre gdbm groff-native"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz"
14SRC_URI[md5sum] = "6fb0e3e52a0f8de5ca63138391b81ce0"
15SRC_URI[sha256sum] = "b35cf19e4a6ba39fd03c6372b8a8760a491cc2e2e4aba3d15023ff291c2894b4"
16
17inherit autotools gettext update-alternatives
18
19EXTRA_OECONF = " \
20 --bindir=${base_bindir} \
21 --enable-etcdir=${sysconfdir} \
22 --enable-fndir=${datadir}/${PN}/${PV}/functions \
23 --enable-site-fndir=${datadir}/${PN}/site-functions \
24 --with-term-lib='ncursesw ncurses' \
25 --with-tcsetpgrp \
26 --enable-cap \
27 --enable-multibyte \
28 --disable-gdbm \
29 --disable-dynamic \
30 zsh_cv_shared_environ=yes \
31"
32
33EXTRA_OEMAKE = "-e MAKEFLAGS="
34
35ALTERNATIVE_${PN} = "sh"
36ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
37ALTERNATIVE_TARGET[sh] = "${base_bindir}/${BPN}"
38ALTERNATIVE_PRIORITY = "100"
39
40export AUTOHEADER = "true"
41
42do_configure () {
43 gnu-configize --force ${S}
44 oe_runconf
45}
46
47do_install_append () {
48 rm -fr ${D}/usr/share
49}
50
51pkg_postinst_${PN} () {
52 touch $D${sysconfdir}/shells
53 grep -q "bin/zsh" $D${sysconfdir}/shells || echo /bin/zsh >> $D${sysconfdir}/shells
54 grep -q "bin/sh" $D${sysconfdir}/shells || echo /bin/sh >> $D${sysconfdir}/shells
55}
56
57FILES_${PN}-dbg += "\
58 ${libdir}/${PN}/${PV}/${PN}/.debug/*.so \
59 ${libdir}/${PN}/${PV}/${PN}/db/.debug/*.so \
60 ${libdir}/${PN}/${PV}/${PN}/net/.debug/*.so \
61"