blob: c14fc9b6826cc03782f8492089ebda17df968a85 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Framebuffer image and doc viewer tools"
2DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \
3 with the main focus being photos."
4HOMEPAGE = "http://linux.bytesex.org/fbida/"
5AUTHOR = "Gerd Hoffmann"
6SECTION = "utils"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
10
11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif"
12
13SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz"
14SRC_URI[md5sum] = "09460b964b58c2e39b665498eca29018"
15SRC_URI[sha256sum] = "7a5a3aac61b40a6a2bbf716d270a46e2f8e8d5c97e314e927d41398a4d0b6cb6"
16
17B = "${WORKDIR}/build"
18
19EXTRA_OEMAKE = "STRIP= 'srcdir=${S}' -f ${S}/GNUmakefile"
20
21PACKAGECONFIG ??= "gif png curl"
22PACKAGECONFIG[curl] = ",,curl"
23PACKAGECONFIG[gif] = ",,giflib"
24PACKAGECONFIG[png] = ",,libpng"
25PACKAGECONFIG[tiff] = ",,tiff"
26PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif"
27PACKAGECONFIG[webp] = ",,libwebp"
28PACKAGECONFIG[lirc] = ",,lirc"
29
30do_compile() {
31 sed -i -e 's# fbgs# \$(srcdir)/fbgs#; s#-Ijpeg#-I\$(srcdir)/jpeg#; s# jpeg/# \$(srcdir)/jpeg/#' ${S}/GNUmakefile
32 sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk
33 sed -i -e 's: cpp: ${TARGET_PREFIX}cpp -I${STAGING_INCDIR}:' ${S}/GNUmakefile
34
35 # Be sure to respect preferences (force to "no")
36 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
37 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'curl', 'curl', '', d)}" ]; then
38 sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile
39 fi
40 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then
41 sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
42 fi
43 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'png', 'png', '', d)}" ]; then
44 sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile
45 fi
46 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'tiff', 'tiff', '', d)}" ]; then
47 sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile
48 fi
49 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'motif', 'motif', '', d)}" ]; then
50 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
51 fi
52 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'webp', 'webp', '', d)}" ]; then
53 sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile
54 fi
55 if [ -z "${@bb.utils.contains('PACKAGECONFIG', 'lirc', 'lirc', '', d)}" ]; then
56 sed -i -e '/^HAVE_LIBLIRC/s/:=.*$/:= no/' ${S}/GNUmakefile
57 fi
58
59 oe_runmake
60}
61
62do_install() {
63 oe_runmake 'DESTDIR=${D}' install
64}
65
66RDEPENDS_${PN} = "ttf-dejavu-sans-mono bash"