blob: 90ac7021649f2d998b42993555708ec8f0d73ecd [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Framebuffer (scriptable) image viewer"
2DESCRIPTION = "FIM (Fbi IMproved) aims to be a highly customizable and scriptable \
3 image viewer targeted at users who are comfortable with software \
4 like the Vim text editor or the Mutt mail user agent."
5SECTION = "utils"
6HOMEPAGE = "http://www.autistici.org/dezperado/fim/"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=fa01bff138cc98a62b8840a157951c88"
10
11PNBLACKLIST[fim] ?= "BROKEN: doesn't build with B!=S (flex: can't open lex.lex)"
12
13# flex with provide /usr/include/FlexLexer.h
14DEPENDS = "flex-native bison-native flex"
15
16SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/fbi-improved/${BPN}-${PV}.tar.gz \
17 file://cross_cc.patch"
18SRC_URI[md5sum] = "d7362dde5541c2b6439c35c6e2bd5046"
19SRC_URI[sha256sum] = "3f6bf2de2952b9adcbeb3db12c2a979e999a81dd1e314a03bc58e24f1ea9f686"
20
21PARALLEL_MAKE = ""
22
23inherit autotools pkgconfig
24
25# Don't use provided regex.c
26EXTRA_OECONF = "fim_cv_regex=no fim_cv_regex_broken=no \
27 --enable-framebuffer \
28 --disable-djvu \
29 --disable-ps \
30 --disable-xcftopnm \
31 --disable-convert \
32 --disable-inkscape \
33 --disable-xfig \
34 --disable-dia \
35 --disable-aa \
36 --disable-sdl \
37 --enable-read-dirs \
38 --enable-recursive-dirs \
39 --enable-custom-status-bar \
40"
41
42# Note: imlib2 is located in meta-efl layer.
43PACKAGECONFIG ?= "jpeg rl hf"
44PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng"
45PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
46PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff"
47PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib"
48PACKAGECONFIG[pdf] = "--enable-poppler,--disable-poppler,poppler"
49PACKAGECONFIG[magick] = "--enable-graphicsmagick,--disable-graphicsmagick,imagemagick"
50PACKAGECONFIG[imlib2] = "--enable-imlib2,--disable-imlib2,imlib2"
51PACKAGECONFIG[rl] = "--enable-readline,--disable-readline,readline"
52PACKAGECONFIG[hf] = "--enable-hardcoded-font,--disable-hardcoded-font"