blob: 15c1b64ee6b90aec076732ed9dde120c3eb7677e [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework"
2LICENSE = "LGPL-3.0"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4DEPENDS = "babl librsvg glib-2.0 gtk+ pango cairo expat zlib libpng jpeg virtual/libsdl json-glib"
5
6EXTRA_OECONF = "--disable-docs"
7
8inherit gnomebase vala gobject-introspection
9
10PACKAGECONFIG ??= ""
11PACKAGECONFIG[jasper] = "--with-jasper,--without-jasper,jasper"
12PACKAGECONFIG[avformat] = "--with-libavformat,--without-libavformat,libav"
13PACKAGECONFIG[lcms] = "--with-lcms,--without-lcms,lcms"
14PACKAGECONFIG[tiff] = "--with-libtiff,--without-libtiff,tiff"
15PACKAGECONFIG[webp] = "--with-webp,--without-webp,webp"
16
17SRC_URI = "http://ftp.gimp.org/pub/${BPN}/0.3/${BP}.tar.bz2 \
18 file://pkgconfig.patch "
19SRC_URI[md5sum] = "c19478321594d715a4cb324a0decda6f"
20SRC_URI[sha256sum] = "846290a790854d1e6b7c17a2d6f82ad7cb14c72e240bd3b81b98cc0ceddbc3ec"
21
22# There are a couple of non-symlink .so files installed into libdir, which need to go into main package
23FILES_${PN}_append = " ${libdir}/gegl-0.3/*.so ${libdir}/gegl-0.3/*.json ${libdir}/libgegl-npd-0.3.so ${libdir}/libgegl-sc-0.3.so"
24FILES_${PN}-dev_append = " ${libdir}/gegl-0.3/*.la ${libdir}/libgegl-0.3.so"
25FILES_${PN}-dev_remove = "${libdir}/lib*.so"
26
27# Fails to build with thumb-1 (qemuarm)
28# gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process':
29# gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275
30ARM_INSTRUCTION_SET = "arm"