blob: b354ae7a1b74bea4c8250c2caaa7779f20c75b26 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "openbox Window Manager"
2SECTION = "x11/wm"
3DEPENDS = "glib-2.0 pango libxml2 virtual/libx11 libcroco librsvg gdk-pixbuf"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7SRC_URI = " \
8 http://icculus.org/openbox/releases/openbox-${PV}.tar.gz \
9 file://0001-Makefile.am-avoid-race-when-creating-autostart-direc.patch \
10"
11
12SRC_URI[md5sum] = "b72794996c6a3ad94634727b95f9d204"
13SRC_URI[sha256sum] = "8b4ac0760018c77c0044fab06a4f0c510ba87eae934d9983b10878483bde7ef7"
14
15inherit autotools gettext update-alternatives pkgconfig distro_features_check
16# depends on virtual/libx11
17REQUIRED_DISTRO_FEATURES = "x11"
18
19ALTERNATIVE_${PN}-core = "x-window-manager"
20ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/openbox"
21ALTERNATIVE_PRIORITY[x-window-manager] = "10"
22
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[imlib2] = "--enable-imlib2,--disable-imlib2,imlib2"
25PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
26PACKAGECONFIG[xrandr] = "--enable-xrandr,--disable-xrandr,libxrandr"
27PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama"
28PACKAGECONFIG[xcursor] = "--enable-xcursor,--disable-xcursor,libxcursor"
29
30PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome ${PN}-config"
31
32PACKAGES_DYNAMIC += "^${PN}-theme-.*"
33
34python populate_packages_prepend() {
35 theme_dir = d.expand('${datadir}/themes/')
36 theme_name = d.expand('${PN}-theme-%s')
37 do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True)
38}
39
40RDEPENDS_${PN} += "${PN}-core ${PN}-config ${PN}-theme-clearlooks"
41FILES_${PN}-core = "${bindir}/openbox ${libdir}/*${SOLIBS}"
42
43FILES_${PN}-lxde += "${datadir}/lxde/ \
44 ${datadir}/lxpanel \
45 ${datadir}/xsessions \
46 ${datadir}/icons"
47
48FILES_${PN}-gnome += " \
49 ${datadir}/gnome \
50 ${datadir}/gnome-session \
51"
52
53FILES_${PN}-config += "${sysconfdir}"