blob: ac60a365f0f4a8b13c350cf3ff49671450ba8773 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "PT Sans Fonts"
2DESCRIPTION = "The PT Sans TTF font set"
3HOMEPAGE = "http://www.paratype.com/public/"
4
5SECTION = "x11/fonts"
6
7LICENSE = "ParaTypeFFL-1.3"
8LIC_FILES_CHKSUM = "file://../PT%20Free%20Font%20License_eng.txt;md5=d720f3a281ed81c3f4cfc465e11b1d0d"
9
10inherit allarch fontcache
11
12# Downloading from fedora because upstream doesn't version its zip file
13# and causes hash build failures
14SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/paratype-pt-sans-fonts/PTSans.zip/c3f5a0e20a75cf628387510a720924a7/PTSans.zip"
15
16SRC_URI[md5sum] = "c3f5a0e20a75cf628387510a720924a7"
17SRC_URI[sha256sum] = "0164f824e03c32c99e8a225853ec168893a04a09ade132e93a674e85ae033b2e"
18
19do_install () {
20 install -d ${D}${datadir}/fonts/X11/TTF/
21 cd ..
22 for i in *.ttf; do
23 install -m 0644 $i ${D}${prefix}/share/fonts/X11/TTF/${i}
24 done
25}
26
27FILES_${PN} += "${datadir}"
28
29pkg_postinst_${PN} () {
30 set -x
31 for fontdir in `find $D/usr/lib/X11/fonts -type d`; do
32 mkfontdir $fontdir
33 mkfontscale $fontdir
34 done
35 for fontdir in `find $D/usr/share/fonts/X11 -type d`; do
36 mkfontdir $fontdir
37 mkfontscale $fontdir
38 done
39}