blob: 0315ed7d66deda1a6a93772a593992f13dff0a7b [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Common X11 scripts and support files"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4
5PR = "r8"
6
7# we are using a gpe-style Makefile
8inherit gpe
9
10SRC_URI[md5sum] = "82f2f84cd96610e8f7b92c700cd31c14"
11SRC_URI[sha256sum] = "cd04c33418f776b1e13fcc7af3d6bd0c7cccd03fbabd7dbcd97f88166cc34210"
12
13SRC_URI_append = " \
14 file://0001-COPYING-add-GPLv2-license-file.patch \
15 file://0002-add-setdpi-Xinit.d-script.patch \
16 file://0003-add-89xdgautostart-Xsession.d-script.patch \
17 file://0005-add-XWindowManager-Xsession.d-script.patch \
18 file://0006-add-support-for-etc-X11-xserver-system.patch \
19 file://0007-use-own-functions-file-instead-etc-init.d-functions.patch \
20 file://0008-xserver-common-add-dpi-and-nocursor-params-for-gta01.patch \
21 file://0009-xserver-common-add-support-for-n900-alias-nokia_rx-5.patch \
22 file://0010-xserver-common-add-support-for-nexus-S-alias-herring.patch \
23 file://0011-xserver-common-add-support-for-nexus-one-alias-mahim.patch \
24 file://0012-xserver-common-add-support-for-gta04-alias-OpenPhoen.patch \
25 file://0013-xserver-common-add-support-for-tuna-alias-Galaxy-Nex.patch \
26 file://0014-Xserver-Start-Xsession-like-x11-common-does.patch \
27 file://0015-xserver-common-disable-TCP-connections.patch \
28"
29
30do_install_append() {
31 sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
32 # Rename all Xsession files not ending with .sh
33 # Unfortunatelly when xinput-calibrator was moved to oe-core
34 # its Xsession file got name 30xinput_calibrate.sh and ls -X sorts it
35 # last, not respecting numbers for sorting them
36 for i in ${D}/${sysconfdir}/X11/Xsession.d/*; do
37 echo $i | grep '.sh$' || mv $i $i.sh
38 done
39}
40
41RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo fbset xinput-calibrator"
42
43RCONFLICTS_${PN} = "xserver-kdrive-common x11-common"
44RREPLACES_${PN} = "xserver-kdrive-common x11-common"
45