blob: b787f0266947cb50b00f52514f6ea616d5487a93 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles"
2DESCRIPTION = "The core analysis suite is a self-contained tool that can be used to\
3investigate either live systems, kernel core dumps created from the\
4netdump, diskdump and kdump packages from Red Hat Linux, the mcore kernel patch\
5offered by Mission Critical Linux, or the LKCD kernel patch."
6
7HOMEPAGE = "http://people.redhat.com/anderson"
8SECTION = "devel"
9
10LICENSE = "GPLv3"
11LIC_FILES_CHKSUM = "file://COPYING3;md5=d32239bcb673463ab874e80d47fae504"
12
13DEPENDS = "zlib readline"
14
15SRC_URI = "https://github.com/crash-utility/${BPN}/archive/${PV}.tar.gz;downloadfilename=${BP}.tar.gz \
16 http://ftp.gnu.org/gnu/gdb/gdb-7.6.tar.gz;name=gdb;subdir=${BP} \
17 file://7001force_define_architecture.patch \
18 file://7003cross_ranlib.patch \
19 file://0001-cross_add_configure_option.patch \
20 file://sim-ppc-drop-LIBS-from-psim-dependency.patch \
21 file://sim-common-sim-arange-fix-extern-inline-handling.patch \
22 file://donnot-extract-gdb-during-do-compile.patch \
23 file://gdb_build_jobs_and_not_write_crash_target.patch \
24 file://remove-unrecognized-gcc-option-m32-for-mips.patch \
25 "
26
27SRC_URI[md5sum] = "155889a233c5230ef1d387858091d294"
28SRC_URI[sha256sum] = "ae98529d42b843f07d795b86b8f8529f64cc607ee3c58affc5a8aa8a506e183d"
29
30SRC_URI[gdb.md5sum] = "a9836707337e5f7bf76a009a8904f470"
31SRC_URI[gdb.sha256sum] = "8070389a5dcc104eb0be483d582729f98ed4d761ad19cedd3f17b5d2502faa36"
32
33inherit gettext
34
35BBCLASSEXTEND = "native cross"
36
37# crash 7.1.3 and before don't support mips64
38COMPATIBLE_HOST = "^(?!mips64).*"
39
40EXTRA_OEMAKE = 'RPMPKG="${PV}" \
41 GDB_TARGET="${TARGET_SYS}" \
42 GDB_HOST="${BUILD_SYS}" \
43 GDB_MAKE_JOBS="${PARALLEL_MAKE}" \
44 '
45
46EXTRA_OEMAKE_class-cross = 'RPMPKG="${PV}" \
47 GDB_TARGET="${BUILD_SYS} \
48 \${GDB_CONF_FLAGS} \
49 --target=${TARGET_SYS}" \
50 GDB_HOST="${BUILD_SYS}" \
51 GDB_MAKE_JOBS="${PARALLEL_MAKE}" \
52 '
53
54EXTRA_OEMAKE_append_class-native = " LDFLAGS='${BUILD_LDFLAGS}'"
55EXTRA_OEMAKE_append_class-cross = " LDFLAGS='${BUILD_LDFLAGS}'"
56
57REMOVE_M32 = "sed -i -e 's/#define TARGET_CFLAGS_ARM_ON_X86_64.*/#define TARGET_CFLAGS_ARM_ON_X86_64\t\"TARGET_CFLAGS=-D_FILE_OFFSET_BITS=64\"/g' ${S}/configure.c"
58
59REMOVE_M32_class-cross = ""
60
61do_configure() {
62 :
63}
64
65do_compile_prepend() {
66 case ${TARGET_ARCH} in
67 aarch64*) ARCH=ARM64 ;;
68 arm*) ARCH=ARM ;;
69 i*86*) ARCH=X86 ;;
70 x86_64*) ARCH=X86_64 ;;
71 powerpc64*) ARCH=PPC64 ;;
72 powerpc*) ARCH=PPC ;;
73 mips*) ARCH=MIPS ;;
74 esac
75
76 sed -i s/FORCE_DEFINE_ARCH/"${ARCH}"/g ${S}/configure.c
77 ${REMOVE_M32}
78 sed -i 's/>/>/g' ${S}/Makefile
79}
80
81do_compile() {
82 oe_runmake ${EXTRA_OEMAKE}
83}
84
85do_install_prepend () {
86 install -d ${D}${bindir}
87 install -d ${D}/${mandir}/man8
88 install -d ${D}${includedir}/crash
89
90 install -m 0644 ${S}/crash.8 ${D}/${mandir}/man8/
91 install -m 0644 ${S}/defs.h ${D}${includedir}/crash
92}
93
94do_install_class-target () {
95 oe_runmake DESTDIR=${D} install
96}
97
98do_install_class-native () {
99 oe_runmake DESTDIR=${D}${STAGING_DIR_NATIVE} install
100}
101
102do_install_class-cross () {
103 install -m 0755 ${S}/crash ${D}/${bindir}
104}
105
106RDEPENDS_${PN} += "liblzma"
107RDEPENDS_${PN}_class-native = ""
108RDEPENDS_${PN}_class-cross = ""
109
110# Causes gcc to get stuck and eat all available memory in qemuarm builds
111# jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o -
112ARM_INSTRUCTION_SET = "arm"