blob: f21f91446ea76b0257d04827bb57273a3f44b49e [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001ESCRIPTION = "The GNU Compact Disc Input and Control library (libcdio) contains a library for CD-ROM and CD image access."
2HOMEPAGE = "http://www.gnu.org/software/libcdio/"
3SECTION = "libs"
4
5LICENSE = "GPLv3+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7
8DEPENDS = "ncurses"
9
10SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz"
11SRC_URI[md5sum] = "d154476feaac5a7b5f180e83eaf3d689"
12SRC_URI[sha256sum] = "4972cd22fd8d0e8bff922d35c7a645be0db0ab0e7b3dfaecc9cd8272429d6975"
13
14inherit autotools pkgconfig
15
16PACKAGES += "${PN}-utils"
17
18FILES_${PN} = "${libdir}/${PN}${SOLIB}"
19FILES_${PN}-utils = "${bindir}/*"
20
21python populate_packages_prepend () {
22 glibdir = d.expand('${libdir}')
23 do_split_packages(d, glibdir, '^lib(.*)\.so\..*', 'lib%s', 'gstreamer %s library', extra_depends='', allow_links=True)
24}
25