blob: 1070246c860bf03674e30626bf87229669b124ae [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Library for reading mod-like audio files"
2HOMEPAGE = "http://modplug-xmms.sf.net"
3
4LICENSE = "PD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c9182faa1f7c316f7b97d404bcbe3685"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/modplug-xmms/libmodplug-${PV}.tar.gz"
8SRC_URI[md5sum] = "5f30241db109d647781b784e62ddfaa1"
9SRC_URI[sha256sum] = "77462d12ee99476c8645cb5511363e3906b88b33a6b54362b4dbc0f39aa2daad"
10
11inherit autotools pkgconfig
12
13EXTRA_OECONF = "--disable-option-checking"
14
15# NOTE: autotools_stage_all does nothing here, we need to do it manually
16do_install_append() {
17 install -d ${D}${includedir}/libmodplug
18 install -m 0644 ${S}/src/modplug.h ${D}${includedir}/libmodplug
19 install -m 0644 ${S}/src/modplug.h ${D}${includedir}/
20}
21