blob: 9d9a6342e64fb5847ab5366330a1e02b37a76567 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Opus Audio Codec"
2DESCRIPTION = "The Opus codec is designed for interactive \
3speech and audio transmission over the Internet. It is \
4designed by the IETF Codec Working Group and incorporates \
5technology from Skype's SILK codec and Xiph.Org's CELT codec."
6HOMEPAGE = "http://www.opus-codec.org/"
7SECTION = "libs/multimedia"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;md5=e304cdf74c2a1b0a33a5084c128a23a3"
10
11SRC_URI = "http://downloads.xiph.org/releases/opus/opus-${PV}.tar.gz"
12SRC_URI[md5sum] = "1f08a661bc72930187893a07f3741a91"
13SRC_URI[sha256sum] = "0e290078e31211baa7b5886bcc8ab6bc048b9fc83882532da4a1a45e58e907fd"
14
15S = "${WORKDIR}/opus-${PV}"
16
17inherit autotools pkgconfig
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[fixed-point] = "--enable-fixed-point,,"
21PACKAGECONFIG[float-approx] = "--enable-float-approx,,"
22
23EXTRA_OECONF = "--with-NE10-includes=${STAGING_DIR_TARGET}${includedir} \
24 --with-NE10-libraries=${STAGING_DIR_TARGET}${libdir} \
25 --enable-asm \
26 --enable-intrinsics \
27 "
28
29python () {
30 if d.getVar('TARGET_FPU', True) in [ 'soft' ]:
31 d.appendVar('PACKAGECONFIG', ' fixed-point')
32
33 # Ne10 is only available for armv7 and aarch64
34 if any((t.startswith('armv7') or t.startswith('aarch64')) for t in d.getVar('TUNE_FEATURES', True).split()):
35 d.appendVar('DEPENDS', ' ne10')
36}
37
38# Fails to build with thumb-1 (qemuarm)
39#| {standard input}: Assembler messages:
40#| {standard input}:389: Error: selected processor does not support Thumb mode `smull r5,r7,r1,r4'
41#| {standard input}:418: Error: selected processor does not support Thumb mode `smull r5,r6,r4,r1'
42#| {standard input}:448: Error: selected processor does not support Thumb mode `smull r4,r5,r1,r0'
43#| {standard input}:474: Error: selected processor does not support Thumb mode `smull r0,r4,r8,r1'
44#| {standard input}:510: Error: selected processor does not support Thumb mode `smull fp,r0,r10,r1'
45#| {standard input}:553: Error: selected processor does not support Thumb mode `smull fp,r1,r10,r3'
46#| {standard input}:741: Error: selected processor does not support Thumb mode `smull r3,r0,r6,r10'
47#| {standard input}:761: Error: selected processor does not support Thumb mode `smull fp,r2,r3,r9'
48#| {standard input}:773: Error: selected processor does not support Thumb mode `smull fp,r3,r5,r8'
49#| make[2]: *** [celt/celt.lo] Error 1
50ARM_INSTRUCTION_SET = "arm"