blob: 648818e7220a1cab46bd5adb03d404849d4416e6 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "VPX multi-format codec"
2DESCRIPTION = "The BSD-licensed libvpx reference implementation provides en- and decoders for VP8 and VP9 bitstreams."
3HOMEPAGE = "http://www.webmproject.org/code/"
4BUGTRACKER = "http://code.google.com/p/webm/issues/list"
5SECTION = "libs/multimedia"
6LICENSE = "BSD"
7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=d5b04755015be901744a78cc30d390d4"
9
10SRC_URI += "http://storage.googleapis.com/downloads.webmproject.org/releases/webm/${BP}.tar.bz2 \
11 file://libvpx-configure-support-blank-prefix.patch \
12 "
13SRC_URI[md5sum] = "49e59dd184caa255886683facea56fca"
14SRC_URI[sha256sum] = "306d67908625675f8e188d37a81fbfafdf5068b09d9aa52702b6fbe601c76797"
15
16# ffmpeg links with this and fails
17# sysroots/armv4t-oe-linux-gnueabi/usr/lib/libvpx.a(vpx_encoder.c.o)(.text+0xc4): unresolvable R_ARM_THM_CALL relocation against symbol `memcpy@@GLIBC_2.4'
18ARM_INSTRUCTION_SET = "arm"
19
20CFLAGS += "-fPIC"
21
22export CC
23export LD = "${CC}"
24
25VPXTARGET_armv5te = "armv5te-linux-gcc"
26VPXTARGET_armv6 = "armv6-linux-gcc"
27VPXTARGET_armv7a = "armv7-linux-gcc"
28VPXTARGET ?= "generic-gnu"
29
30CONFIGUREOPTS = " \
31 --target=${VPXTARGET} \
32 --enable-vp9 \
33 --enable-libs \
34 --disable-install-docs \
35 --disable-static \
36 --enable-shared \
37 --prefix=${prefix} \
38 --libdir=${libdir} \
39 --size-limit=16384x16384 \
40"
41
42do_configure() {
43 ${S}/configure ${CONFIGUREOPTS}
44}
45
46do_install() {
47 oe_runmake install DESTDIR=${D}
48 chown -R root:root ${D}
49}