blob: d91cbcbbb3278070e71760bd3bb7a009265522d8 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "FoxtrotGPS is a map and GPS application using OpenStreetMap"
2AUTHOR = "Joshua Judson Rosen <rozzin@geekspace.com>"
3HOMEPAGE = "http://www.foxtrotgps.org/"
4SECTION = "x11/applications"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7DEPENDS = "curl gtk+ libglade sqlite3 libexif gpsd bluez4 intltool-native"
8
9PNBLACKLIST[foxtrotgps] ?= "${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', 'bluez5 conflicts with bluez4 and bluez5 is selected in DISTRO_FEATURES', '', d)}"
10
11SRC_URI = "http://www.foxtrotgps.org/releases/${BP}.tar.gz"
12SRC_URI[md5sum] = "6777d448ee9d3ba195f9d26ea90e3163"
13SRC_URI[sha256sum] = "ae9706285510554cc0813ac92522e0d1672b0ddb065307bfacfcff3c328f6adb"
14
15inherit autotools pkgconfig perlnative gconf
16
17PR = "r2"
18
19do_configure_prepend() {
20 if [ -f ${S}/configure.in ] ; then
21 mv ${S}/configure.in ${S}/configure.ac
22 fi
23}
24
25RDEPENDS_${PN} += "python perl"
26RRECOMMENDS_${PN} = "gpsd"