blob: 012806a69ccff60b73b3b2254fce69925bc14c95 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "GDAL is a translator library for raster geospatial data formats"
2HOMEPAGE = "http://www.gdal.org/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=0952e17969fab12227096b5228f23149"
5
6DEPENDS = "proj sqlite3 tiff json-c"
7
8SRC_URI = "ftp://download.osgeo.org/gdal/${PV}/${BP}.tar.xz"
9
10SRC_URI[md5sum] = "2e126d7c6605691d38f3e71b945f5c73"
11SRC_URI[sha256sum] = "20e1042cff15a71038459a299732fb342428aea9912f32df30c85790fcab6302"
12
13inherit autotools-brokensep lib_package binconfig
14
15EXTRA_OECONF = "--without-perl \
16 --without-php \
17 --without-ruby \
18 --without-python \
19 \
20 --without-grass \
21 --without-libgrass \
22 --without-cfitsio \
23 --without-dds \
24 --without-gta \
25 --without-pcidsk \
26 --without-ogdi \
27 --without-fme \
28 --without-hdf4 \
29 --without-hdf5 \
30 --without-pg \
31 --without-jpeg12 \
32 --without-ogdi \
33 --without-netcdf \
34 --without-openjpeg \
35 --without-fgdb \
36 --without-ecw \
37 --without-kakadu \
38 --without-mrsid \
39 --without-jp2mrsid \
40 --without-mrsid_lidar \
41 --without-msg \
42 --without-bsb \
43 --without-grib \
44 --without-mysql \
45 --without-ingres \
46 --without-odbc \
47 --without-dods_root \
48 --without-xml2 \
49 --without-spatialite \
50 --without-pcre \
51 --without-dwgdirect \
52 --without-dwgdirect \
53 --without-idb \
54 --without-sde \
55 --without-sde-version \
56 --without-epsilon \
57 --without-webp \
58 --without-opencl \
59 --without-opencl-include \
60 --without-opencl-lib \
61 --without-freexl \
62 --without-pam \
63 --without-poppler \
64 --without-podofo \
65 --without-podofo-lib \
66 --without-podofo-extra-lib-for-test \
67 --without-static_proj4 \
68 --without-perl \
69 --without-php \
70 --without-ruby \
71 --without-python \
72 --without-java \
73 --without-mdb \
74 --without-jvm-lib \
75 --without-jvm-lib-add-rpath \
76 --without-rasdaman \
77 --without-armadillo \
78 \
79 --with-pcraster=internal \
80 --with-geotiff=internal \
81 \
82 --with-sqlite3=${STAGING_EXECPREFIXDIR} \
83 --with-libtiff=${STAGING_EXECPREFIXDIR} \
84 --with-libjson-c=${STAGING_EXECPREFIXDIR} \
85 --with-expat=${STAGING_EXECPREFIXDIR} \
86"
87
88EXTRA_OEMAKE += "INST_DATA="${datadir}/gdal""
89
90PACKAGECONFIG ?= "geos png jasper"
91PACKAGECONFIG[geos] = "--with-geos,--without-geos,geos"
92PACKAGECONFIG[lzma] = "--with-liblzma,--without-liblzma,xz"
93PACKAGECONFIG[png] = "--with-png,--without-png,libpng"
94PACKAGECONFIG[gif] = "--with-gif,--without-gif,giflib"
95PACKAGECONFIG[jpeg] = "--with-jpeg,--without-jpeg,jpeg"
96PACKAGECONFIG[z] = "--with-libz,--without-libz,zlib"
97PACKAGECONFIG[jasper] = "--with-jasper,--without-jasper,jasper"
98PACKAGECONFIG[curl] = "--with-curl,--without-curl,curl"
99
100do_configure_prepend () {
101 # The configure script has many hardcoded paths to search
102 # for the library headers when using external libraries,
103 # workaround it.
104 sed -e 's,/usr/include,NON_EXISTENT_DIR,g' \
105 -e 's,/usr/lib,NON_EXISTENT_DIR,g' \
106 -i ${S}/configure.in
107}
108
109FILES_${PN} += "${libdir}/gdalplugins"
110
111# | gdalserver.c:124:21: error: storage size of 'sHints' isn't known
112# | struct addrinfo sHints;
113# | ^
114PNBLACKLIST[gdal] ?= "BROKEN: fails to build with gcc-5"