blob: 5e3d04e29426a3f3067a73dddbf8713724e099be [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "The Geolocation Service"
2DESCRIPTION = "Geoclue is a D-Bus service that provides location information. \
3The primary goal of the Geoclue project is to make creating location-aware applications \
4as simple as possible, while the secondary goal is to ensure that no application \
5can access location information without explicit permission from user."
6LICENSE = "GPLv2.0+"
7SECTION = "console/network"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=8114b83a0435d8136b47bd70111ce5cd"
10
11DEPENDS = "glib-2.0 dbus dbus-glib json-glib libsoup-2.4"
12
13inherit autotools pkgconfig gtk-doc
14
15SRC_URI = " \
16 http://www.freedesktop.org/software/geoclue/releases/2.0/geoclue-${PV}.tar.xz \
17 file://soup-session-fix.patch \
18"
19
20SRC_URI[md5sum] = "401ff99d530b177c62afacef0a33efd9"
21SRC_URI[sha256sum] = "4a82f184e55a163d86e0ad69bbe1bba9960bb5094220fe1f01350bceda8c67a1"
22
23PACKAGECONFIG[geoip] = "--enable-geoip-server,--disable-geoip-server,geoip"
24
25EXTRA_OECONF += " \
26 --with-dbus-service-user=root \
27 --with-dbus-sys-dir=${sysconfdir}/dbus-1/system.d \
28"
29
30FILES_${PN} += " \
31 ${datadir}/dbus-1/system-services/org.freedesktop.GeoClue2.service \
32 ${datadir}/geoclue-2.0/geoclue-interface.xml \
33"