blob: 938af2ef76e57344e0b43f36653e72070bdeb319 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SECTION = "x11/network"
2SUMMARY = "Mail user agent"
3DEPENDS = "gtk+ libetpan openssl aspell curl libgcrypt"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e059bde2972c1790af786f3e86bac22e"
6
7PNBLACKLIST[claws-mail] ?= "depends on blacklisted libetpan"
8
9inherit autotools pkgconfig gettext
10
11# translation patch: http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=1774
12SRC_URI = "\
13 ${SOURCEFORGE_MIRROR}/project/claws-mail/Claws%20Mail/${PV}/claws-mail-${PV}.tar.bz2;name=archive "
14SRC_URI[archive.md5sum] = "4c5ac7b21f0ed17d0f6404124c2229a4"
15SRC_URI[archive.sha256sum] = "ed70975a5056b3ffc4fe6e977f0d9606febc1499763c090241b029a73ff24e65"
16
17do_configure_append() {
18 cd ${S}/po ; for PO in *.po ; do MO=`echo $PO | sed s/\\.po//`.gmo ; if ! test -f $MO ; then msgfmt $PO -o $MO ; fi ; done; cd ${B}
19}
20
21PACKAGECONFIG ??= "startup-notification dbus"
22PACKAGECONFIG[enchant] = "--enable-enchant,--disable-enchant,enchant"
23PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
24PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus dbus-glib"
25PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,openldap"
26
27# FIXME: maemo builds may want --enable-maemo
28# FIXME: some platforms may want --enable-generic-umpc
29EXTRA_OECONF = " \
30 --disable-manual \
31 --disable-crash-dialog \
32 --disable-jpilot \
33 --disable-trayicon-plugin \
34 --disable-spamassassin-plugin \
35 --disable-bogofilter-plugin \
36 --disable-pgpcore-plugin \
37 --disable-pgpmime-plugin \
38 --disable-pgpinline-plugin \
39 --disable-dillo-viewer-plugin \
40 --disable-valgrind \
41"
42
43# Remove enchant references:
44do_install_prepend() {
45 sed -i -e 's:${STAGING_INCDIR}:${includedir}:g;s:${STAGING_LIBDIR}:${libdir}:g' claws-mail.pc
46}
47
48# Work-around broken GPE icon lookup:
49do_install_append() {
50 rm -r ${D}${datadir}/icons
51 install -d ${D}${datadir}/pixmaps
52 install -m 0644 ${S}/claws-mail.png ${D}${datadir}/pixmaps/
53 sed -i 's/Icon=[^.]*$/&.png/' ${D}${datadir}/applications/claws-mail.desktop
54}
55
56RSUGGESTS_${PN} = "claws-plugin-gtkhtml2-viewer claws-plugin-mailmbox claws-plugin-rssyl"