blob: 35c891e7a7f059c22d7564acaef7430e3e375ae6 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Apcupsd a daemon for controlling APC UPSes"
2
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c12853cc7fdf20d17b4fddefd26b7802"
5
6SRC_URI = "http://garr.dl.sourceforge.net/project/apcupsd/apcupsd%20-%20Stable/3.14.10/apcupsd-${PV}.tar.gz"
7SRC_URI[md5sum] = "5928822d855c5cf7ac29655e3e0b8c23"
8SRC_URI[sha256sum] = "0707b5ec9916fbde9e44eb8d18037c8d8f75dfd6aeef51aba5487e189eef2032"
9
10PNBLACKLIST[apcupsd] ?= "BROKEN: doesn't build with B!=S"
11
12inherit autotools
13
14LD = "${CXX}"
15
16EXTRA_OECONF = "--without-x \
17 --enable-usb \
18 --with-distname=${DISTRO}"
19
20do_configure() {
21 export topdir=${S}
22 cp -R --no-dereference --preserve=mode,links -v ${S}/autoconf/configure.in ${S}
23
24 if ! [ -d ${S}/platforms/${DISTRO} ] ; then
25 cp -R --no-dereference --preserve=mode,links -v ${S}/platforms/unknown ${S}/platforms/${DISTRO}
26 fi
27
28 gnu-configize --force
29 # install --help says '-c' is an ignored option, but it turns out that the argument to -c isn't ignored, so drop the complete '-c path/to/strip' line
30 sed -i -e 's:$(INSTALL_PROGRAM) $(STRIP):$(INSTALL_PROGRAM):g' ${S}/autoconf/targets.mak
31 # Searching in host dirs triggers the QA checks
32 sed -i -e 's:-I/usr/local/include::g' -e 's:-L/usr/local/lib64::g' -e 's:-L/usr/local/lib::g' ${S}/configure
33
34 # m4 macros are missing, using autotools_do_configure leads to linking errors with gethostname_re
35 oe_runconf
36}
37
38do_install_append() {
39 rm ${D}${datadir}/hal -rf
40}
41
42