blob: bc88143ed6315189e7ee3ffaed4760364deee5c2 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "An implementation of the GEIS interface"
2DESCRIPTION = "An implementation of the GEIS (Gesture Engine Interface and Support) \
3interface\
4GEIS is a library for applications and toolkit programmers which \
5provides a consistent platform independent interface for any \
6system-wide input gesture recognition mechanism."
7
8HOMEPAGE = "https://launchpad.net/geis"
9
10LICENSE = "GPLv3 & LGPLv3"
11LIC_FILES_CHKSUM = " \
12 file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6 \
13 file://COPYING.GPL;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
14"
15
16inherit autotools pkgconfig python3native lib_package distro_features_check
17
18REQUIRED_DISTRO_FEATURES = "x11"
19
20DEPENDS += "grail dbus-glib python3 virtual/libx11 libxext libxi libxcb dbus frame"
21
22SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.xz"
23SRC_URI[md5sum] = "2ff9d76a3ea5794516bb02c9d1924faf"
24SRC_URI[sha256sum] = "8a60f5683852094038904e690d23cc5a90a980fc52da67f0f28890baa25c70eb"
25
26EXTRA_OECONF = "--disable-integration-tests"
27
28FILES_${PN}-bin = "${bindir}"
29RDEPENDS_${PN}-bin = " \
30 python3-compression \
31 python3-core \
32 python3-crypt \
33 python3-ctypes \
34 python3-fcntl \
35 python3-misc \
36 python3-pickle \
37 python3-shell \
38 python3-stringold \
39 python3-subprocess \
40 python3-textutils \
41 python3-threading \
42"
43
44FILES_${PN} += " \
45 ${datadir}/geisview \
46 ${libdir}/${PYTHON_DIR}/site-packages/geis* \
47 ${libdir}/${PYTHON_DIR}/site-packages/_*.so \
48"
49
50FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"
51
52FILES_${PN}-dev += "${libdir}/${PYTHON_DIR}/site-packages/_*.la"
53
54FILES_${PN}-staticdev += "${libdir}/${PYTHON_DIR}/site-packages/_*.a"