blob: 16c21d3c51ea3cc2a7c1d3ac59724efc4343d452 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Manage plain dm-crypt and LUKS encrypted volumes"
2DESCRIPTION = "Cryptsetup is used to conveniently setup dm-crypt managed \
3device-mapper mappings. These include plain dm-crypt volumes and \
4LUKS volumes. The difference is that LUKS uses a metadata header \
5and can hence offer more features than plain dm-crypt. On the other \
6hand, the header is visible and vulnerable to damage."
7HOMEPAGE = "http://code.google.com/p/cryptsetup/"
8SECTION = "console"
9LICENSE = "GPL-2.0-with-OpenSSL-exception"
10LIC_FILES_CHKSUM = "file://COPYING;md5=32107dd283b1dfeb66c9b3e6be312326"
11
12DEPENDS = "util-linux lvm2 popt libgcrypt"
13
14SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/v1.7/${BP}.tar.xz"
15SRC_URI[md5sum] = "56c385fe87fc2b6873df4b7f89202d0f"
16SRC_URI[sha256sum] = "075524a7cc0db36d12119fa79116750accb1c6c8825d5faa2534b74b8ce3d148"
17
18inherit autotools gettext pkgconfig
19
20# Use openssl because libgcrypt drops root privileges
21# if libgcrypt is linked with libcap support
22PACKAGECONFIG ??= "openssl"
23PACKAGECONFIG[openssl] = "--with-crypto_backend=openssl,,openssl"
24PACKAGECONFIG[gcrypt] = "--with-crypto_backend=gcrypt,,libgcrypt"
25
26RRECOMMENDS_${PN} = "kernel-module-aes-generic \
27 kernel-module-dm-crypt \
28 kernel-module-md5 \
29 kernel-module-cbc \
30 kernel-module-sha256-generic \
31"
32
33EXTRA_OECONF = "--enable-static"